Vectr 2 help

#1
On windows/Osm2.1

I finally figured installing vectr out with som help. But im trying to upload the default firmware on arduino and it just keeps giving me errors. Unsure where to go from here.

Re: Vectr 2 help

#2
Ok so trying upload the firmware (vectr Beta 2) to the chip thru Arduino it gives me a error when I try to verify it. The error states.. "Variable or field 'pattern_strobe' declared void." it also highlights row 35 in pink. No idea what to do from here.

Re: Vectr 2 help

#3
dejesus425 wrote:Ok so trying upload the firmware (vectr Beta 2) to the chip thru Arduino it gives me a error when I try to verify it. The error states.. "Variable or field 'pattern_strobe' declared void." it also highlights row 35 in pink. No idea what to do from here.


What version of Arduino are you using?

In Arduino, under Tools > Board, what do you have selected?

Re: Vectr 2 help

#5
So i figured out my problem was i wasnt naming the firmwares before saving but my new problem is that when i import custom modes downloaded off the facebook page into the modes folder and create firmwares using them after firmwares cease to save in the folder at all. tested this by reinsatlling vectr and using the default givens to create fWs which worked fine, but as i said after i added customs they dont want to save

Re: Vectr 2 help

#6
wwetnaojw wrote:So i figured out my problem was i wasnt naming the firmwares before saving but my new problem is that when i import custom modes downloaded off the facebook page into the modes folder and create firmwares using them after firmwares cease to save in the folder at all. tested this by reinsatlling vectr and using the default givens to create fWs which worked fine, but as i said after i added customs they dont want to save


It is possible that you're trying to use a mode that was posted for Vectr version 1 instead of 2, which from my understanding are not compatible. Can you post a reply in here and attach the mode file you're trying to use?

I'm actually working on a video tutorial i'm going to post later that goes through the entire process for both Vectr 1, and Vectr 2, which i should have up here something shortly.

Re: Vectr 2 help  Selected Answer

#8
wwetnaojw wrote:https://lookaside.fbsbx.com/file/Metakineticfluxonsteroids.mode?token=AWxE56Hw7eac76b56xDclMphwtMNypFmS2cilASRybrG4cJToKIDOE8lyzgpxay7DGyvzNh5aQQ5MSSkhReYXkK2dYrIVvWZYIWIxCQocd0DOn5M6NK3B5SZ9CPLfuLvw0T23IzHfnnEMV8GAhrmu__X


Ah yes, see that is a mode file for Vectr 1, not for Vectr 2. These mode files are not interchangeable, so at this time you can't use a Vectr 1 mode file on Vectr 2

Re: Vectr 2 help

#9
Ah I also found that same issue while finishing up a tutorial I was doing for Vectr and trying to upload the default firmware. You didn't mention what version of Arduino you're using so I have no idea whether that's your issue or not, but I do know that there are issues (with that exact error) due to old versions of Arduino.

Re: Vectr 2 help

#10
wwetnaojw wrote:https://lookaside.fbsbx.com/file/Metakineticfluxonsteroids.mode?token=AWxE56Hw7eac76b56xDclMphwtMNypFmS2cilASRybrG4cJToKIDOE8lyzgpxay7DGyvzNh5aQQ5MSSkhReYXkK2dYrIVvWZYIWIxCQocd0DOn5M6NK3B5SZ9CPLfuLvw0T23IzHfnnEMV8GAhrmu__X


Watch the tutorial I created for Vectr 2 that should clear up a lot of things for you:
http://osf.guru/viewtopic.php?f=25&t=40

Who is online

Users browsing this forum: No registered users and 2 guests

cron