Vectr default Firmware showing error

#1
The below message keeps coming up when I try to load the default firmware through arduino 1.6.5:
I've tried making other firmwares and loading them but all of them give the same error and jump to the same Array spot, any suggestions?




Arduino: 1.6.5 (Windows 8.1), Board: "Arduino/Genuino Uno"

default:35: error: variable or field 'pattern_strobe' declared void
default:35: error: 'PatternState' was not declared in this scope
default:35: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:35: error: expected primary-expression before 'bool'
default:36: error: variable or field 'pattern_tracer' declared void
default:36: error: 'PatternState' was not declared in this scope
default:36: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:36: error: expected primary-expression before 'bool'
default:37: error: variable or field 'pattern_morph' declared void
default:37: error: 'PatternState' was not declared in this scope
default:37: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:37: error: expected primary-expression before 'bool'
default:38: error: variable or field 'pattern_sword' declared void
default:38: error: 'PatternState' was not declared in this scope
default:38: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:38: error: expected primary-expression before 'bool'
default:39: error: variable or field 'pattern_wave' declared void
default:39: error: 'PatternState' was not declared in this scope
default:39: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:39: error: expected primary-expression before 'bool'
default:40: error: variable or field 'pattern_dynamo' declared void
default:40: error: 'PatternState' was not declared in this scope
default:40: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:40: error: expected primary-expression before 'bool'
default:41: error: variable or field 'pattern_shifter' declared void
default:41: error: 'PatternState' was not declared in this scope
default:41: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:41: error: expected primary-expression before 'bool'
default:42: error: variable or field 'pattern_triple' declared void
default:42: error: 'PatternState' was not declared in this scope
default:42: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:42: error: expected primary-expression before 'bool'
default:43: error: variable or field 'pattern_stepper' declared void
default:43: error: 'PatternState' was not declared in this scope
default:43: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:43: error: expected primary-expression before 'bool'
default:44: error: variable or field 'pattern_random' declared void
default:44: error: 'PatternState' was not declared in this scope
default:44: error: 'state' was not declared in this scope
In file included from C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/Arduino.h:24:0,
from default.ino:2:
default:44: error: expected primary-expression before 'bool'
variable or field 'pattern_strobe' declared void

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

Re: Vectr default Firmware showing error

#2
Your problem is simple, Vectr is not supported with Arduino 1.6.5, update to 1.6.7 and you should be good to go!!

Install the default firmware first to get all the settings to make your lights compatible with the VectrUI. The latest version is Vectr 0.3.4.

Who is online

Users browsing this forum: No registered users and 1 guest

cron